Swifttdial Systems Limited - Voice Call Quality Degradation | Kenya – Incident details

Voice Call Quality Degradation | Kenya

Resolved
Operational
Started about 3 years agoLasted 2 days

Affected

Voice

Operational from 8:33 AM to 10:23 AM

Updates
  • Resolved
    Resolved

    This issue was resolved.

  • Monitoring
    Monitoring

    We implemented a fix and currently monitoring the result.

  • Identified
    Identified

    We are currently facing partial voice call quality degradation on some of our Kenya Voice services due to restrained resources. The issue has been identified and communication relayed to our provider for immediate resolution.

    Our sincere apologies for the inconvenience caused

    Regards, Voice Team